Need Expert IT Services In The Chicagoland Area? Call Us Now! (815) 261-9602

ATTENTION: Adobe Security Flaw Leaves Your Data At Risk

Adobe is in the news once again – releasing their important software updates for the following:

  • Flash
  • Acrobat
  • Reader

The company has put out a whopping 69 security updates in an attempt to fix multiple security bugs recently found in the program. Updating your Adobe is a must as they repair holes where malicious viruses and internet attackers can access your computer and its documents.

Adobe Security

Here’s a run-down of what some of the security updates are resolving – and why you need to make sure you apply them immediately:

  • CVE-2015-4446, CVE-2015-5106 and CVE-2015-5090 resolve something known as “validation bypass issues” that could otherwise allow hackers privileges on your systems.
  • CVE-2015-5091 resolves another validation bypass issue wherein hackers could otherwise exploit the issue and perform a denial-of-service attack – stealing sensitive information.

Adobe is one of many companies releasing updates this week, and most of which are related or to or in direct result of security breaches in the software. This exemplifies the increase in malicious internet attacks and reminds us of the importance of updating our software.

Most internet browsers will automatically update Adobe flash when they boot up, but it is still highly recommended that you update the other Adobe appendages like Reader, Acrobat, and Photoshop to secure your computer.

Adobe still has multiple bugs to fix but these 69 security updates is a good start at upgrading the software.

Aquarius Technology Solutions manages all of your technology – handling all patches and updates before it’s too late. Contact us at (815) 261-9602 or send us an email at info@aquariusit.solutions to find out more about our managed IT services – available at a flat-rate monthly fee.

Find out how we can help your Illinois Business!

Connect With Your Chicago IT Experts

Send Us A Message Using The Form Below.